2007/7/11

EC-CUBE はロリポップでは動かない…


よくある質問:

Q:ロリポップのレンタルサーバでEC-CUBEを動かすにはどうしたらいいのですか?

A:残念ながら、ロリポップではEC-CUBEは動きません…

大半の格安レンタルサーバではEC-CUBEのインストールができないんです、残念ながら。
PHPはクリアしてるんだけど、ロリポップに代表される安価なサーバだとMySQLのバージョンが 4.0系 が多くEC-CUBEのシステム要件を満たしておりません。
さくらインターネットのレンタルサーバも同様です。

特に、EC-CUBEはサブクエリを多用しており、サブクエリに対応したのはMySQL4.1からなので、この部分はどうしようもない…
PostgreSQLを採用しているレンタルサーバは少ないので、やはりMySQL4.1以降が載っているところを探すことになりそうです。

それ以外にも、乗り越えるべき課題はいくつかあるのでレンタルサーバを借りるのであれば、開発コミュニティなどで動作事例のあるサーバを借りることをオススメします。
特に「あとでSSLが動かないことがわかった」などは致命的になったりもするので、要注意。

あ、もちろん弊社エスキュービズムにもお気軽にお問い合わせください、ね。