2007/11/13

EC-CUBE2.0 動かないなぁ


EC-CUBE 2.0.0 betaがリリースというニュースを聞き、「おおっ」と興奮して試してみたが、序盤でエラーが出てしまい調査を停滞中。

おそらくロックオン様と開発環境が違うためだと思われる。
ロックオン様は PostgreSQL がメインとお聞きしていたけど、ウチは MySQL。
DB周辺の相性が悪い?

必要な修正箇所を1点だけ確認できているのでメモを残しておこう。

------------------

/data/class/pages/products/LC_Page_Products_Detail.php

[714行目]
before:$where = “del_flg = 0 AND product_id = ? AND status = 1″;

after:$where = “del_flg = 0 AND T3.product_id = ? AND status = 1″;

------------------

どこかに、2.0.0 beta 不具合連絡サイトみたいなのがあると便利だと思うのだが…

(不具合という言葉は開発者には抵抗感アリアリだと思うけど ^-^;)

とりあえず、このページと開発コミュニティを活用してみるけど、おそらくメジャーバージョンアップの直後は、様々な情報を飛び交わした方が良いモノができる気がする。


運営者

  • 株式会社エスキュービズム
  • 〒105-0011 東京都港区芝公園2-4-1芝パークビル A館 4階
  • TEL : 03-6430-6730(代表)
  • HP:https://s-cubism.jp/